The Chainlink

So.... I've been looking around for a trainer to use during the winter and am having a tough time weeding through all the types and models since I have really no idea what I want.

I think what would help me best is to hear personal reviews from you guys...I'm looking to spend under $300.

So what do you own? Would you buy something else if you were to do it all over again? What have you heard... etc.

Views: 65

Reply to This

Replies to This Discussion

So I got my blackburn ultra in the mail yesterday, set it up and put my bike in.

Something is NOT right. The resistance seems way too high and there is a sensation of slipping while I'm pedaling.

I adjusted the tightness on the back tire up and down and made sure everything was tight.

Any tips from you wise ones?
Sounds like it needs to be broken in. BUT when in doubt call the company.



Ashley said:
So I got my blackburn ultra in the mail yesterday, set it up and put my bike in.

Something is NOT right. The resistance seems way too high and there is a sensation of slipping while I'm pedaling.

I adjusted the tightness on the back tire up and down and made sure everything was tight.

Any tips from you wise ones?
Possibly. But last night I couldn't even ride the stupid thing for 3 minutes. I have a feeling the ball bearings need to be greased but I'm afraid that might be above my skill level. I'm pretty good with that stuff but in reviews I've been reading they say to be really careful you don't use too watery of lube and you don't get it in certain parts etc.

I think I might actually return it to the REI store on Halsted and eat the shipping cost. After reading more reviews it seems that the there were lots of complaints that the resistance was way too difficult new, and that after a few months it began to become increasingly unreliable.

Frustrated!

Tommie said:
Sounds like it needs to be broken in. BUT when in doubt call the company.



Ashley said:
So I got my blackburn ultra in the mail yesterday, set it up and put my bike in.

Something is NOT right. The resistance seems way too high and there is a sensation of slipping while I'm pedaling.

I adjusted the tightness on the back tire up and down and made sure everything was tight.

Any tips from you wise ones?

RSS

Groups

© 2008-2016   The Chainlink Community, L.L.C.   Powered by

Disclaimer  |  Report an Issue  |  Terms of Service